import Foundation
let pattern = #"\[url=([^][\s]+)](.*?)\[/url]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"[url=https://test.com]my link[/url]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a href='$1' target='_blank'>$2</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)