import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[url=([^][\\s]+)](.*?)\\[/url]";
final String string = "[url=https://test.com]my link[/url]";
final String subst = "<a href='$1' target='_blank'>$2</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}