// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[url=([^][\s]+)](.*?)\[/url]").unwrap();
let string = "[url=https://test.com]my link[/url]";
let substitution = "<a href='$1' target='_blank'>$2</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}