const regex = new RegExp('\\[url=([^][\\s]+)](.*?)\\[/url]', 'g')
const str = `[url=https://test.com]my link[/url]`;
const subst = `<a href='$1' target='_blank'>$2</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);